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About this guide
To help you find the right information about working with Applied AutoMod®, 
this section briefly describes the purpose, organization, and typographical 
conventions used in this guide. It also lists additional documentation that you 
can reference to learn more about the product and explains how to contact 
software support.

Purpose
This guide explains how to install and uninstall the Applied AutoMod software, 
as well as the AutoMod Runtime Licenses and the Network License Server. It 
also contains activation information and troubleshooting suggestions.

Organization
This guide contains the following sections:

Applied AutoMod 
Installation Guide

Overview Introduces AutoMod and the installation process.

Preparing for installation Lists the hardware and software you need before you 
install and run the AutoMod packages.

Installing AutoMod Describes how to install and uninstall the base 
AutoMod software. Also explains how to authorize the 
software and troubleshoot problems.

Installing the AutoMod 
Runtime License

Describes how to install a runtime license for AutoMod. 
Also explains how to authorize the software and 
troubleshoot problems.

Installing the Network 
License Server

Describes how to install, start, stop, and restart the 
Network License Server. NLS allows you to run Applied 
Materials products on any machine in a local area 
network. Also explains how to install and run Applied 
software on clients and on remote servers. Includes 
troubleshooting suggestions.



Applied Materials Confidential | 2

Applied AutoMod 12.6.1
Installation Guide

Conventions

The following table describes the writing conventions used in this guide.

Related documentation
The following table lists additional documentation deliverables provided with 
Applied AutoMod.

This Represents Example

bold; Title Caps Menu names, tab names, options, 
and commands that you need to 
choose to complete a step of a 
procedure.

On the File menu, click Exit.

Title Caps The names of windows and dialog 
boxes.

The Select a Model to Run dialog box 
opens.

italic • Emphasis or an important term 
that you should pay particular 
attention to.

• Folders, packages, file names, and 
script names.

AutoMod cannot be installed in a directory 
with a space in its name.

Delete the .am2rc and .mviewrc files.

ALL CAPS The names of keys on your keyboard. Click the first record in the range, press 
SHIFT, and then click the last record in the 
range.

monospace All code including keywords, data 
types, constants, method names, 
class names, variables, and 
interface names when used in an 
example or in the main body of text.

To use DateOfWeek structures in AutoMod, 
you must first declare the DateOfWeek 
structure.

<angle brackets> • Required parameters when used in 
commands.

• Placeholder variable names in 
code.

Type servinst -f <tmpfile> where 
<tmpfile> is the name of the temporary 
file. 

MultiModelSync -me <data_file_path>

[square brackets] Optional arguments when used in 
commands.

MultiModelSync -p [port number]

Document title Purpose

AutoMod Release Notes Describes the main enhancements, fixed 
problems, and known issues associated 
with the latest release.

AutoMod Documentation Library Provides a single point of access to all 
the AutoMod user documentation 
described here.

AutoMod Online Help Provides task-oriented, reference, and 
context-sensitive help information when 
using AutoMod and the components 
bundled with it.
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Software support
If you have questions about the installation or upgrade process, contact your 
local support center. To obtain the latest contact information for your support 
center, click the following link, scroll down the login page, and then select your 
region:

www.softwaresupport.appliedmaterials.com

AutoMod User’s Guide Provides task-oriented, reference, and 
conceptual information about how to 
build, run, and analyze a model using 
AutoMod, and how to design, animate, 
and record model graphics.

AutoMod Model Communications User’s 
Guide

Explains how to run models as a 
combined simulation on networked 
machines, control models from third-
party applications, and communicate 
with an OPC server 

Getting Started with AutoMod Explains general simulation principles 
and provides step-by-step instructions 
for using AutoMod to build, run and 
analyze models.

Beginning AutoMod Tutorial Provides guidance on the basic steps of 
creating, editing, and running an 
AutoMod model.

Designing Legacy ACE Graphics Tutorial Provides guidance on the steps of 
building graphic representations to use 
in AutoMod path mover models.

Using Kinematics Tutorial Provides guidance on the use of graphics 
in a movement system and how to 
define and configure a machine for a 
kinematic system.

AutoStat 5.0 Release Notes Provides important information about 
the AutoStat version bundled with this 
release of AutoMod.

Document title Purpose

www.softwaresupport.appliedmaterials.com
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Overview
The AutoMod software enables you to build, run, and analyze a model that 
graphically simulates a manufacturing process. The model can assist you with 
capacity analysis, production planning, and scheduling. 

AutoMod is easy to install, but there are several things you should understand 
first. Please read these instructions carefully before you proceed with the 
installation. 

Preparing for installation
This section describes the hardware and software required to install and use the 
Applied AutoMod software package.

System requirements
Most professional PC-compatible computers built after the year 2000 are able 
to run AutoMod and its associated applications. The recommended system 
specifications are:

O/S AutoMod 12.6.1 is supported as a 32-bit and 64-bit application on:

• Windows 8 and 8.1
• Windows 7
• Windows Vista
• Windows Server 2008
• Windows Server 2003
• AutoMod 12.6.1 also requires .NET Framework 3.5

CPU Intel P4/Centrino or AMD Athlon XP/FX/Mobile, 2.8 GHz or faster.

(Intel Celeron/Atom and AMD Duron/Sempron are not 
recommended. Netbooks and thin-client machines are not 
recommended. Small caches on these processors and systems 
degrade execution speed.)

Graphics Graphics needs are dependent on the complexity and scope of your 
model. Most graphics processors animate correctly, but 
workstation-class 3D graphics processors are recommended for 
best performance. A minimum of OpenGL hardware acceleration, 
non-shared memory of at least 128 MB, and PCI Express 1.0 are 
recommended for basic performance.

RAM 512 MB minimum. 1 GB or more recommended.

Disk The AutoMod packages require the following minimum disk space 
(plus model storage space):

AutoMod 250 MB

AutoMod Runtime License 60 MB

NLS 5 MB

NLS also requires a network adapter and a network connection that supports 
the Internet Protocol (TCP/IP).

AutoMod uses either a USB hardware key or Sentinel software key for local 
authorization. Legacy parallel port keys are still supported. Contact customer 
support for any questions.
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Software compatibility
This release of the AutoMod product has been certified with the following 
operating system and third-party software.

 Note Installers are available for both 32-bit and 64-bit AutoMod 
applications.

• Windows 8 and 8.1 32-bit and 64-bit

• Windows 7 32-bit and 64-bit

• Windows Vista 32-bit and 64-bit

• Windows Server 2008 32-bit and 64-bit licensed from the Network License 
Server (NLS)

• Windows Server 2003 32-bit and 64-bit licensed from the Network License 
Server (NLS)

• Microsoft .NET Framework 3.5

• Microsoft Visual Studio .NET 2010

• AutoStat 5.0

• AutoSched AP 10.1.0

 Note AutoMod versions 12.5 and later will not run with versions of 
AutoStat older than AutoStat 5.0, nor will it run with versions of AutoSched 
AP older than 10.0.3.
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Installing AutoMod

Preparing to install

Exporting your models

 Complete the following steps before installing the software

1. Export all models.

2. Delete the <modelname>.dir directory for each model, because it is 
version-specific.

3. Delete the .am2rc and .mviewrc files, which are also version-specific. 

These files may be located in each model directory, in the home directory, 
and/or in the lib directory of the previous installation.

Uninstalling previous versions
If you have an earlier version of AutoMod, and you want to install the new 
version to the same directory, you should uninstall the previous version before 
installing the new version. If you want to keep the previous version, install the 
new version to a new directory. To uninstall a previous version of AutoMod, see 
“Uninstalling AutoMod” on page 15. 

If you have questions, contact customer support before continuing.

Installing the latest service packs and updates
To successfully run AutoMod 12.6.1 with .NET 3.5 and with the Visual Studio 
2010 redistributables, you must install the appropriate service pack for your 
operating system (listed below). With Windows Server 2003 and Windows 
Server 2008, you must also run Windows Update to get the correct updates.

• Windows 7 - Service Pack 1 or later

• Windows Vista Business - Service Pack 1

• Windows 8 - Service Pack 1

• Windows Server 2008 - Service Pack 2

• Windows Server 2003 - Service Pack 2

» Tip Prior to installing this release, make a backup of your models.

» Tip The SimController utility makes it easy to manage multiple versions of 
AutoMod. Using this tool, you can easily make any installed version of 
AutoMod active at any time. For more information, see the AutoMod User’s 
Guide.

 Note We recommend that you always use the latest service packs for your 
operating system.



Applied Materials Confidential | 7

Applied AutoMod 12.6.1
Installation Guide

Installing the AutoMod software
Export all existing models before installing a new version.

 To begin installation

1. Obtain the AutoMod installation software from the customer portal (only 
customers with a current maintenance contract can access the portal; 
contact your local support center for information on accessing the portal).

2. Log in as a user with administrative privileges.

3. Right-click AutoMod_version#.exe and select Run as administrator.

4. Follow the prompts on the screen (refer to the following sections for 
guidelines regarding installation options). 

5. When asked whether to restart now, select No; wait to restart your 
machine until after the installation is finished. 

Selecting a directory for installation
When selecting an installation directory, keep the following in mind:

• AutoMod cannot be installed in a directory with a space in its name.

• The name of the installation directory cannot contain characters with 
diacritical marks like the umlaut, grave, acute or circumflex accent marks, 
tilde, cedilla, and so on. The directory names (and the names of your 
AutoMod models) should include only standard English letters and 
numbers.

• The pathname for any model, including the file name, must include fewer 
than 72 characters.

• If you want to install and run different versions of the software on the same 
machine, each version of the software must be installed in a different 
directory. 

Selecting the type of installation
There are three types of installation: Custom Setup, Full Installation, and 
Typical.

Custom Setup A custom installation allows you to select the components you 
want to install; each of the available components is described in the following 
section. Use this option if you are sure which components you want to install or 
if you want to add components to an existing installation (the existing 
installation must be the same version as the components you are installing).

Full Installation A full installation installs all features, modules, and utilities. 
Use this option if you are unsure which features you will need.

Typical A typical installation installs the most commonly used options. This is 
a good option if you are a new AutoMod user. A typical installation includes 
AutoMod, AutoStat, AutoView, the SimController, the AutoMod sample models, 
sample graphics, the system utilities, and documentation. It does not include 
Process Server, the OPC Utility, or the rest of the sample models.
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Selecting the components of a custom installation
If you select a custom installation, you can choose to install any combination of 
the following components.

Applied AutoMod You must install AutoMod.

Applied AutoMod Modules The following modules are available for 
installation:

Sample Models and Files You can install sample models for AutoMod, 
AutoStat, and other Applied products. You can install any combination of demo 
models. 

 Note The software required for model communications is automatically 
installed with the AutoMod program. However, the Model Communications 
module (MCM) and the Model Communications Plus module must be 
purchased separately.

Option Description

AutoStat™ This option installs AutoStat. AutoStat is a statistical analysis 
and run management package that helps you experiment with 
your models. AutoStat must be purchased and authorized 
separately.

AutoView This option installs AutoView. AutoView is an extension to 
AutoMod that allows you to view or create animation clips, or 
“movies,” of a simulation. If you want to create model 
animations, you must purchase and authorize AutoView 
separately.

Process Server This option installs the Process Server software. The Process 
Server allows you to make model runs on remote machines 
with the Model Communications module or AutoStat. The 
Process Server must be installed on each machine that you 
want to use to make remote runs. 

OPC Utility This option installs the OPC Utility. The OPC Utility is a software 
tool that accompanies the Model Communications module. The 
utility allows you to easily create a configuration file that you 
can use to open connections in an emulation model. For more 
information, refer to the AutoMod Help.

SimController This option installs the SimController. The SimController gives 
you a streamlined way to run models and view results. You can 
also use the SimController to organize models into projects, 
view model information, compare model runs, and manage 
installed versions of AutoMod. An AutoMod license includes this 
module.

Path Editor This option installs the Path Editor. The Path Editor lets you 
automatically place control points along paths in a path mover 
system. This simplifies the construction of non-accumulating 
path mover systems, which provide faster runtime 
performance than accumulating systems. An AutoMod license 
includes this module.

 Note The Sample Graphics option installs a library of sample entity 
graphics that you can use to replace default entity graphics in a model. The 
Getting Started with AutoMod option installs the Getting Started with 
AutoMod book, as well as the example models that are used with the book.



Applied Materials Confidential | 9

Applied AutoMod 12.6.1
Installation Guide

System Utilities The system utilities consist of programs that are necessary 
for authorizing software. 

The system utilities consist of the following programs:

Documentation This option installs the AutoMod library of .pdf manuals, 
including the AutoMod User’s Guide and the tutorials. (The Help system is 
installed with AutoMod.]

Selecting the program folder
Choose a Start menu program folder for AutoMod, or create a new folder.

Selecting the Home directory
The Home directory defines the default directory for opening or saving models 
from within AutoMod. The Home directory also defines the location where 
configuration files can be saved to affect multiple models (as opposed to 
defining a separate configuration for each model). Select the directory in which 
you are most likely to store your models, such as C:\models.

Identifying the license server
If you are using a license server to authorize your software, you can type the 
name of the server here. If you like, you can leave this blank and type the 
server name when you open the application. If you do not know the name of 
your license server, ask your system administrator.

If you are not using a license server, leave this blank; you will need to install a 
Sentinel key and type authorization codes when you open the AutoMod 
software. For more information, see “Authorizing the software” on page 11.

Setting environment variables 
When prompted, click Yes to let the installation program set the system 
environment variables for you. The program has collected this information from 
your answers to the preceding questions. The environment variables are set to 
the following:

 Note If you are installing for the first time, you must install the system 
utilities.

Utility Description

Sentinel Driver The Sentinel driver coordinates the hardware key with the 
authorization codes. 

Visual C++ 2010 
Redistributables

These libraries are needed to run AutoMod. You can omit this 
option if you have previously installed AutoMod 12.5 or later 
on this computer.

 Note Do not select a directory that contains a space or special character 
in the directory path, nor the top level of the drive (such as “C:\”).

Variable Definition

ASI The AutoMod installation directory.

PATH Modified to include the bin directory of the installation.

HOME The home directory you selected during installation.
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The install script also sets a fourth environment variable, MAKE_MODE, which is 
not acknowledged in the confirmation window. This variable tells the compiler 
what operating system you are compiling on.  MAKE_MODE is set to Win32 on 
Windows machines.

Managing multiple versions of the software
If you have more than one version of AutoMod installed on your machine, you 
can manage versions with the SimController’s Manage AutoMod Installations 
tool. The tool lets you search for installed versions and add them to the 
SimController’s version list. Then, to make a version active, you simply click the 
version in the Manage AutoMod Installations tool’s drop-down list. For more 
information, see the AutoMod User’s Guide.

You can also open a specific version of the software by using the Command 
Prompt Setup in the software’s program group in the Windows Start menu. A 
Command Prompt Setup is available in the Start menu for each installation of 
AutoMod 10.0 or higher. 

If you start the software from a standard command prompt or from within 
Windows, the version that opens is determined by the value of the ASI 
environment variable. To use a specific version, you must change the value of 
the ASI environment variable to point to the directory of the installation you 
want to use (the PATH environment variable uses the ASI variable to define the 
location of the bin directory).

Setting display properties
After you have installed the software, set the following display properties in 
your Control Panel:

Colors = 32K or higher

Resolution = 1024x768 or higher

Fonts = Small Fonts

 Note If you do not let the installation program set the system 
environment variables for you, you must set them manually after 
completing the installation. If you set the variables yourself, be sure to use 
backslashes, not forward slashes, in your paths.

 Note Changing the active version of AutoMod in the SimController does 
not change your ASI environment variable, and it does not affect the 
operation of AutoMod independent of the Controller. 

» Tip To manage versions of the software earlier than 10.0 (that is, 
AutoMod 9.1 and lower), you can create your own command prompt setup 
for each version. For more information, see the November, 2000 issue of 
AutoFlash. (You can download the AutoFlash from the Total Product Support 
Web site.)

! Important If you do not use these settings, the software’s windows and 
graphics might not display properly.
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Authorizing the software
Applied software can be authorized either locally or remotely. A local 
authorization allows you to run the software on a particular machine. Local 
authorizations require either a Sentinel hardware key or a Sentinel software 
key and authorization codes. You can obtain these from customer support. A 
remote authorization allows you to run multiple instances of the software 
simultaneously, on one machine or on multiple machines that are connected by 
a network. The number of instances of the software that you can run 
simultaneously is limited by the number of licenses you purchase. Remote 
authorizations require the Network License Server.

If you are authorizing software using the Network License Server (NLS), see the 
authorization instructions in “Running software on clients” in the NLS 
installation instructions.

To authorize the software locally, you must first install either the Sentinel 
software key or the Sentinel hardware key as described in the following 
procedures.

Installing the Sentinel software key
The Sentinel software key is installed using the Sentinel Remote Update System 
(RUS) utility and is locked to the host machine used to run the AutoMod 
software.

 Note Software keys are not available for Academic licenses (which must 
be authorized using either a hardware key or Network License Server).

 To authorize the software using a local software key, you must 
install the key as follows

1. On the computer where you want to install the software key, open the 
SimController (available on the Windows Start menu from the Utilities 
folder in the AutoMod program group). 

2. In the SimController, click File > Software Key Setup. The RUS window 
opens with the first tab Collect Status Information active. 

3. Verify that the Installation of a new protection key option is selected, then 
click Collect Information.

The collected information is used to create a .c2v file, which is a 
“fingerprint” of the computer where the software key will be installed.

4. Navigate to the location where you want to save the .c2v file, enter a file 
name, then click Save.

5. Email the created .c2v file to AutoMod support (see “Software support” on 
page 3). 

6. After AutoMod support receives your .c2v file, they generate your software 
key and then email you a .v2c file. This step requires some time for 
AutoMod support to complete.

7. After you receive the .v2c file from AutoMod support, open the RUS utility 
(see step 2).

8. Click the Apply License File tab of the RUS utility.

9. Click the ... button and navigate to the location of the .v2c file, select the 
file name, and then click Open.

10. Click the Apply Update button to complete the installation of the software 
key.
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The software key is now installed.

After installing the software key, you are now ready to enter your authorization 
codes using the Simulation License Manager. For more information, see 
“Authorizing AutoMod” on page 12 and the subsequent sections.

Installing the Sentinel hardware key
The Sentinel hardware key is a physical security key that is installed in a 
parallel or USB port on the host machine used to run the AutoMod software.

 To authorize the software using a local hardware key, you must 
install the key as follows

1. Turn off your machine before installing the Sentinel key.

2. Install the key into a parallel or USB port (depending on the key type).

3. Turn on your machine and log in as a user with read/write privileges. 

The key is automatically recognized (for information about any error 
messages related to the Sentinel key, see “Troubleshooting” on page 15).

You are now ready to authorize Applied software. Refer to the following sections 
for more information.

Authorizing AutoMod

 To authorize AutoMod

1. On the Start menu, click AutoMod. The Authorization window opens.

2. Click Password Version. The Simulation License Manager opens. See 
“Simulation License Manager” in the AutoMod Help File for instructions on 
authorizing your software. 

 Note The installed software key is locked to this computer. If you want 
to move the software key to another computer, see “Transferring a 
Sentinel software key” on page 14

 Note You can install the USB key into a USB hub; however, the key must 
be installed into one of the hub’s first ten USB ports. If your hub has more 
than ten ports, the additional ports are not recognized by AutoMod.

 Note If you are running AutoMod on a remote machine using Windows 
Remote Desktop, your Sentinel key may reside on either the local or the 
remote machine. However, the machine with the key must have the 
Sentinel driver installed. A standard AutoMod installation installs this driver. 
If you prefer not to install AutoMod but still need the driver, you can 
perform an AutoMod Custom Setup installation and install just the driver. 
See “System Utilities” on page 9.

 Note The software automatically detects the Sentinel Key identification 
number. If you’ve used multiple keys on the same machine, the 
Identification number list will contain multiple entries. In this case, select 
the currently installed key in the list.
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Authorizing AutoView
If you have purchased a license to create AutoView animation clips of model 
simulation, you need to authorize AutoView. AutoView is authorized the first 
time you run a simulation that is defined to generate AutoView description files.

If you are authorizing software using the Network License Server, see the 
authorization instructions in “Running software on clients” in the NLS 
installation instructions.

 To authorize AutoView locally

1. Open a model in AutoMod and edit the run control. 

2. Select the AutoView check box to generate animation description files 
during a snap (for more information, see the AutoMod Help).

3. Run the model. The Authorization window appears. 

4. Click Password Version. The Simulation License Manager opens. See 
“Simulation License Manager” in the AutoMod Help File for instructions on 
authorizing your software. 

Authorizing AutoStat
If you have purchased AutoStat, you must authorize it before you can open a 
model for analysis. 

If you are authorizing software using the Network License Server, see the 
authorization instructions in “Running software on clients” in the NLS 
installation instructions.

 To authorize AutoStat locally

1. In the Start menu, click AutoStat. 

The AutoStat window opens.

2. Click File > Open and navigate to a model that you want to open (the 
model must have been built in AutoMod before it can be opened in 
AutoStat). 

3. Click Open to open the model. The Authorization window opens. 

4. Click Password Version. The Simulation License Manager opens. See 
“Simulation License Manager” in the AutoMod Help File for instructions on 
authorizing your software. 

Authorizing the MMS Server
If you have purchased the Model Communications Plus module, you need to 
authorize the MMS Server before you can start a synchronized simulation.

If you are authorizing software using the Network License Server, see the 
authorization instructions in “Running software on clients” in the NLS 
installation instructions.

 Note The software automatically detects the Sentinel Key identification 
number. If you’ve used multiple keys on the same machine, the 
Identification number list will contain multiple entries. In this case, select 
the currently installed key in the list.

 Note The software automatically detects the Sentinel Key identification 
number. If you’ve used multiple keys on the same machine, the 
Identification number list will contain multiple entries. In this case, select 
the currently installed key in the list.
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To authorize the MMS Server locally

1. Open a model in AutoMod that contains the MMS functions. 

2. Run the model. The Authorization window appears. 

3. Click Password Version. The Simulation License Manager opens. See 
“Simulation License Manager” in the AutoMod Help File for instructions on 
authorizing your software.

Alternatively, you can authorize MMS from the command line: 

1. Open a command prompt and type multimodelsync.

A text menu appears.

2. Type the number 1 to authorize the software locally.

3. Type the first set of authorization codes at the Code 1: prompt and press 
ENTER.

4. Type the second set of authorization codes at the Code 2: prompt and 
press ENTER.

The MMS Server is now authorized.

Transferring a Sentinel software key
You can transfer a Sentinel software key from one machine to another using the 
Sentinel Remote Update System (RUS) utility.

 To transfer a Sentinel software key

On the computer to which you want to transfer the software key (that 
is, the recipient computer): 

1. Open the SimController (available on the Windows Start menu from the 
Utilities folder in the AutoMod program group). 

2. In the SimController, click File > Software Key Setup. The RUS window 
opens with the first tab Collect Status Information active. 

3. Click the Transfer License tab.

4. In the Collect information about the recipient computer section of the 
window click the ... button, enter a file name, and then click Save.

5. Click Collect and Save Information. This saves the recipient computer's 
information to an .id file.

6. Transfer this .id file to the computer where the key is currently installed 
(source computer).

On the source computer:  

1. Open the SimController, click File > Software Key Setup. The RUS 
window opens.

2. Click the Transfer License tab of the RUS utility.

3. In the Generate the license transfer file section of the window, select 
the software key to transfer. 

4. Click the ... button that corresponds to the recipient information file, 
navigate to the .id file from the recipient computer, and then click Open. 

5. Click the ... button that corresponds to the license transfer file, enter a file 
name for the .h2h file, then click Save. 

 Note After authorization, the MMS Server attempts to start a 
synchronized simulation; if the default model data file cannot be found in 
the current directory, the software returns an error.



Applied Materials Confidential | 15

Applied AutoMod 12.6.1
Installation Guide

6. Click Generate License Transfer File. This generates a .h2h file 
containing the software key information for the recipient computer. 

Transfer this .h2h file to the recipient computer. 

On the recipient computer:

1. Open the SimController, and then click File > Software Key Setup. The 
RUS window opens. 

2. Click the Apply License File tab.

3. Click the ... button, navigate to the .h2h file, and then click Open.

4. Click the Apply Update button to complete the transfer of the software 
key. 

The software key transfer is complete.

Uninstalling AutoMod
Uninstall utilities are included with the AutoMod installation.

 To uninstall AutoMod

1. From the Start menu, select the Uninstall option for the software you want 
to remove. 

A dialog box asks you to confirm your intention.

2. Click Yes and follow the instructions on the screen.

The software is deleted from your machine.

You can also uninstall AutoMod by using Add or Remove Programs in the 
Control Panel.

Troubleshooting
This section contains information about how to solve problems that you might 
experience during and after software installation. If the problem you are 
experiencing is not listed in this section, contact customer support for further 
assistance.

Solving problems during installation

Problem During installation, I get an error that says cannot add \bin to 
path.

Solution This error occurs when you are installing in a directory with an 
incompatible name. To fix the problem, reinstall into a directory that does not 
contain a space or special character in its name or in the name of any directory 
in its path.

Solving problems starting the software

Problem When I open the software, I get the message: 
SENTC_DRIVER_NOT_INSTALLED.

Solution Edit the devices on your machine, locate the Sentinel device, 
highlight it, and click Start. (For information about how to edit devices, see 
your operating system’s documentation.) If error messages persist, turn off the 
machine and restart. If you still get error messages, contact customer support.
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Problem When I open the software, some windows are cropped or I can’t see 
some buttons in the interface.

Solution Delete the .am2rc and the .mviewrc files from each model directory, 
the home directory, and the \lib directory of the installation. Also, ensure that 
the display is set to a resolution of 1024x768 or higher. Then reopen the 
software.

Problem After typing authorization codes, the Authorization dialog box closes 
but the software doesn’t start. When I try to start the software again, I’m again 
prompted for authorization codes. 

Solution The environment variables are not set correctly on your machine. 
Verify that you have administrative privileges (which are required to set the 
value of environment variables on your machine), then either reinstall the 
software and let the installation script set the environment variable values for 
you or set the values manually in your operating system (see “Setting 
environment variables” on page 9).

Problem When I open the software, I can’t see the drawing grid.

Solution Set your display colors to 32K colors or higher.

Problem When I open the software, I get an error indicating that the ASI 
environment variable has not been set.

Solution The environment variables are not set correctly on your machine. 
Verify that you have administrative privileges (which are required to set the 
value of environment variables on your machine), then either reinstall the 
software and let the installation script set the environment variable values for 
you or set the values manually in your OS (see “Setting environment variables” 
on page 9). 

Solving problems using the software

Problem When manipulating the view, placing graphics, or toggling the 
display of graphic entities, the software sometimes fails.

Solution This could indicate that the software is incompatible with your 
graphics card’s hardware acceleration. To fix the problem, try lowering the 
hardware acceleration setting defined on the Troubleshooting tab of the 
Display control panel in Windows. Often, slight reductions of the hardware 
acceleration will solve the problem; however, you might need to reduce the 
acceleration significantly or turn it off completely.

Problem When I try to run a model in AutoStat, the Select a Model to Run 
dialog box opens before each run.

Solution This error occurs when a model is stored in a location that includes a 
space or special character anywhere in its path. To fix the problem, move the 
model to a directory that does not contain a space or special character in its 
name or in the name of any directory in its path. 

Problem When I try to run a model, AutoMod repeatedly displays the error 
Can’t run model. Would you like to build model?

Solution This error occurs when you are installing in a directory with an 
incompatible name. To fix the problem, reinstall into a directory that does not 
contain a space or special character in its name or in the name of any directory 
in its path.
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Problem When I try to run a model, I get a dialog box asking for 
authorization codes. I’ve already authorized the software.

Solution The edit environment and simulation environment each have 
separate authorization codes. To authorize the simulation environment, type 
the codes labeled Runtime.

Problem When I run a model, the model graphics don’t appear in the 
Simulation window.

Solution This error could indicate that the software is incompatible with your 
graphics card’s hardware acceleration. To fix the problem, try lowering the 
hardware acceleration setting defined on the Troubleshooting tab of the 
Display control panel in Windows. Often, slight reductions of the hardware 
acceleration will solve the problem; however, you might need to reduce the 
acceleration significantly or turn it off completely. 

Problem When I close a menu, some remnants of the menu remain visible on 
the screen.

Solution In Windows, open the Display Properties dialog box, click the 
Effects tab, and clear Use transition effects for menus and tips. Clearing 
this option prevents menu remnants that occur with some graphics cards.

Problem AutoStat opens but does not execute. An error message is 
displayed. The model does run in AutoMod.

Solution Shorten the model name or place the model higher in your directory 
structure; the entire pathname, including the file name, must contain fewer 
than 72 characters.
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Installing the AutoMod Runtime License

Preparing to install
The AutoMod Runtime License software only runs models created with the same 
version and build of the AutoMod software. If you want to run a model created 
with a previous version or build, you should contact the person or firm who built 
your model to get an updated version of the model.

If you have questions, contact customer support before continuing.

Installing the AutoMod Runtime License software

 To begin installation

1. Obtain the AutoMod Runtime installation software from the customer portal 
(only customers with a current maintenance contract can access the portal; 
contact your local support center for information on accessing the portal).

2. Log in as a user with administrative privileges.

3. Right-click AutoMod_Runtime_version#.exe and select Run as 
administrator.

4. Follow the prompts on the screen (refer to the following sections for 
guidelines regarding installation options). 

5. When asked whether to restart now, select No; wait to restart your 
machine until after the installation is finished. 

Selecting a directory for installation
When selecting an installation directory, keep the following in mind:

• AutoMod cannot be installed in a directory with a space in its name.

• The name of the installation directory cannot contain characters using 
diacritical marks like the umlaut, grave, acute or circumflex accent marks, 
tilde, cedilla, and so on. The directory names should include only standard 
English letters and numbers.

• The pathname for any model, including the file name, must include fewer 
than 72 characters.

• If you want to install and run different versions of the software on the same 
machine, each version of the software must be installed in a different 
directory. 

Selecting the type of installation
There are three types of installation: Custom Setup, Full Installation, and 
Typical.

Custom Setup A custom installation allows you to select the components you 
want to install; each of the available components is described in the following 
section. Use this option if you are sure which components you want to install or 
if you want to add components to an existing installation (the existing 
installation must be the same version as the components you are installing).

Full Installation A full installation installs all features, modules, and utilities. 
Use this option if you are unsure which features you will need.
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Typical A typical installation installs all runtime components except Microsoft 
VM and ProcServ.

Selecting the components of a custom installation
If you select a custom installation, you can choose to install any combination of 
the following components.

Applied AutoMod You must install AutoMod Runtime.

Applied AutoMod Modules The following modules are available for 
installation:

System Utilities The system utilities consist of programs that are necessary 
for authorizing software. 

The system utilities consist of the following programs:

Documentation This option installs the AutoMod library of .pdf manuals, 
including the AutoMod Runtime User’s Guide. (The Help system is installed with 
AutoMod Runtime.]

Selecting the program folder
Choose a Start menu program folder or create a new folder.

Option Description

AutoStat™ This option installs AutoStat. AutoStat is a statistical analysis 
and run management package that helps you experiment with 
your models. AutoStat must be purchased and authorized 
separately.

AutoView This option installs AutoView. AutoView is an extension to 
AutoMod that allows you to view or create animation clips, or 
“movies,” of a simulation. If you want to create model 
animations, you must purchase and authorize AutoView 
separately.

ProcServ This option installs the Process Server software. The Process 
Server allows you to make model runs on remote machines 
with the Model Communications module or AutoStat. The 
Process Server must be installed on each machine that you 
want to use to make remote runs. 

 Note If you are installing for the first time, you must install the system 
utilities.

Utility Description

Sentinel Driver The Sentinel driver coordinates the hardware key with the 
authorization codes. 

Visual C++ 2010 
Redistributables

These libraries are needed to run AutoMod. You can omit this 
option if you have previously installed AutoMod 12.5 or later 
on this computer.
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Selecting the Home directory
The Home directory defines the default directory for opening models from 
within AutoMod. The Home directory also defines the location where 
configuration files can be saved to affect multiple models (as opposed to 
defining a separate configuration for each model). Select the directory in which 
you are most likely to store your models, such as C:\models.

Setting environment variables 
When prompted, select Yes to let the installation program set the system 
environment variables for you. Setting the environment variables assigns 
directories to variables used by AutoMod to locate needed files.

The environment variables are set to the following:

The install script also sets a fourth environment variable, MAKE_MODE, which is 
not acknowledged in the confirmation window. This variable tells the compiler 
what operating system you are compiling on.  MAKE_MODE is set to Win32 on 
Windows machines.

Managing multiple versions of the software
If you have more than one version of AutoMod installed on your machine, you 
can open a specific version of the software by using the Command Prompt 
Setup in the software’s program group in the Windows Start menu. A Command 
Prompt Setup is available in the Start menu for each installation of AutoMod 
10.0 or higher. 

If you start the software from a standard command prompt or from within 
Windows, the version that opens is determined by the value of the ASI 
environment variable. To use a specific version, you must change the value of 
the ASI environment variable to point to the directory of the installation you 
want to use (the PATH environment variable uses the ASI variable to define the 
location of the bin directory).

 Note Do not select a directory that contains a space or special character 
in the directory path, nor the top level of the drive (such as “C:\”).

Variable Definition

ASI The AutoMod installation directory.

PATH Modified to include the bin directory of the installation.

HOME The home directory you selected during installation.

 Note If you do not let the installation program set the system 
environment variables for you, you must set them manually after 
completing the installation. If you set the variables yourself, be sure to use 
backslashes, not forward slashes, in your paths.

» Tip To manage versions of the software earlier than 10.0 (that is, 
AutoMod 9.1 and lower), you can create your own command prompt setup 
for each version. For more information, see the November, 2000 issue of 
AutoFlash. (You can download the AutoFlash from the Total Product Support 
Web site.)
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Setting display properties
After you install the software, set the following in your Control Panel:

Colors = 32K or higher

Resolution = 1024x768 or higher

Fonts = Small Fonts

Authorizing the software
Applied software can be authorized either locally or remotely. A local 
authorization allows you to run the software on a particular machine. Local 
authorizations require either a Sentinel hardware key or Sentinel software key 
and authorization codes. You can obtain these from customer support. A 
remote authorization allows you to run multiple instances of the software 
simultaneously, on one machine or on multiple machines that are connected by 
a network. The number of instances of the software that you can run 
simultaneously is limited by the number of licenses you purchase. Remote 
authorizations require the Network License Server.

If you are authorizing software using the Network License Server (NLS), see the 
authorization instructions in “Running software on clients” in the NLS 
installation instructions.

To authorize the software locally, you must first install either the Sentinel 
software key or the Sentinel hardware key as described in the following 
procedures.

Installing the Sentinel software key
The Sentinel software key is installed using the Sentinel Remote Update System 
(RUS) utility and is locked to the host machine used to run the AutoMod 
software.

 To authorize the software using a local software key, you must 
install the key as follows

1. On the computer where you want to install the software key, open the 
SimController (available on the Windows Start menu from the Utilities 
folder in the AutoMod program group). 

2. In the SimController, click File > Software Key Setup. The RUS window 
opens with the first tab Collect Status Information active. 

3. Verify that the Installation of a new protection key option is selected, then 
click Collect Information.

The collected information is used to create a .c2v file, which is a 
“fingerprint” of the computer where the software key will be installed.

4. Navigate to the location where you want to save the .c2v file, enter a file 
name, then click Save.

5. Email the created .c2v file to AutoMod support (see “Software support” on 
page 3). 

6. After AutoMod support receives your .c2v file, they generate your software 
key and then email you a .v2c file. This step requires some time for 
AutoMod support to complete.

7. After you receive the .v2c file from AutoMod support, open the RUS utility 
(see step 2).

! Important If you do not use these settings, windows and graphics within 
AutoMod may not display properly.
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8. Click the Apply License File tab of the RUS utility.

9. Click the ... button and navigate to the location of the .v2c file, select the 
file name, and then click Open.

10. Click the Apply Update button to complete the installation of the software 
key.

The software key is now installed.

After installing the software key, you are now ready to enter your authorization 
codes using the Simulation License Manager. For more information, see 
“Authorizing AutoMod” on page 12 and the subsequent sections.

Installing the Sentinel hardware key
The Sentinel hardware key is a physical security key that is installed in a 
parallel or USB port on the host machine used to run the AutoMod software.

 To authorize the software using a local hardware key, you must 
install the key as follows

1. Turn off your machine before installing the Sentinel key.

2. Install the key into a parallel or USB port (depending on the key type).

3. Turn on your machine and log in as a user with read/write privileges. 

The key is automatically recognized (for information about any error 
messages related to the Sentinel key, see “Troubleshooting” on page 15).

You are now ready to authorize Applied software. Refer to the following sections 
for more information.

Authorizing AutoMod
You must authorize the AutoMod software before you can run a model. 

 To authorize AutoMod

1. In the Start menu, click AutoMod Runtime.

2. Navigate to the location of a model on your machine, then click Open. The 
Authorization window opens. 

 Note The installed software key is locked to this computer. If you want 
to move the software key to another computer, see “Transferring a 
Sentinel software key” on page 14.

 Note You can install the USB key into a USB hub; however, the key must 
be installed into one of the hub’s first ten USB ports. If your hub has more 
than ten ports, the additional ports are not recognized by AutoMod.

 Note If you are running AutoMod on a remote machine using Windows 
Remote Desktop, your Sentinel key may reside on either the local or the 
remote machine. However, the machine with the key must have the 
Sentinel driver installed. A standard AutoMod installation installs this driver. 
If you prefer not to install AutoMod but still need the driver, you can 
perform an AutoMod Custom Setup installation and install just the driver. 
See “System Utilities” on page 9.
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3. Click Password Version. The Simulation License Manager opens. See 
“Simulation License Manager” in the AutoMod Help File for instructions on 
authorizing your software.. 

Authorizing AutoStat
You must authorize AutoStat before you can open a model for analysis. 

If you are authorizing software using the Network License Server, see the 
authorization instructions in “Running software on clients” on page 31.

 To authorize AutoStat locally

1. In the Start menu, click AutoStat. 

The AutoStat window opens.

2. Click File > Open and navigate to a model that you want to open. 

3. Click Open to open the model. The Authorization window opens. 

4. Click Password Version. The Simulation License Manager opens. See 
“Simulation License Manager” in the AutoMod Help File for instructions on 
authorizing your software. 

Using the runtime license
The AutoMod Runtime License software only runs models created with the same 
version and build of the AutoMod software. You need the following to run a 
model with the runtime license:

• <modelname>.exe file

• <modelname>.dir directory

• Any external data files used with the model

 To run a model with the runtime license

1. In Windows, open the directory that contains the model you want to run.

2. Double-click the <modelname>.exe file.

Troubleshooting
This section contains information about how to solve problems that you might 
experience during and after software installation. If the problem you are 
experiencing is not listed in this section, contact customer support for further 
assistance.

Solving problems during installation

Problem During installation, AutoMod displays an error that says cannot add 
\bin to path.

 Note The software automatically detects the Sentinel Key identification 
number. If you’ve used multiple keys on the same machine, the 
Identification number list will contain multiple entries. In this case, select 
the currently installed key in the list.

 Note The software automatically detects the Sentinel Key identification 
number. If you’ve used multiple keys on the same machine, the 
Identification number list will contain multiple entries. In this case, select 
the currently installed key in the list.
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Solution This error occurs when you are installing in a directory with an 
incompatible name. To fix the problem, reinstall into a directory that does not 
contain a space or special character in its name or in the name of any directory 
in its path.

Solving problems starting the software

Problem When I open the software, AutoMod displays the message: 
SENTC_DRIVER_NOT_INSTALLED.

Solution Edit the devices on your machine, locate the Sentinel device, 
highlight it, and click Start. (For information about how to edit devices, see 
your operating system’s documentation.) If error messages persist, turn off the 
machine and restart. If you still get error messages, contact customer support.

Problem After typing authorization codes, the Authorization dialog box closes 
but the software doesn’t start. When I try to start the software again, I’m again 
prompted for authorization codes. 

Solution The environment variables are not set correctly on your machine. 
Verify that you have administrative privileges (which are required to set the 
value of environment variables on your machine), then either reinstall the 
software and let the installation script set the environment variable values for 
you or set the values manually in your operating system (see “Setting 
environment variables” on page 9). 

Problem When I open the software, I get an error indicating that the ASI 
environment variable has not been set.

Solution The environment variables are not set correctly on your machine. 
Verify that you have administrative privileges (which are required to set the 
value of environment variables on your machine), then either reinstall the 
software and let the installation script set the environment variable values for 
you or set the values manually in your operating system (see “Setting 
environment variables” on page 9). 

Solving problems using the software

Problem When manipulating the view or toggling the display of graphic 
entities, the software sometimes fails.

Solution This could indicate that the software is incompatible with your 
graphics card’s hardware acceleration. To fix the problem, try lowering the 
hardware acceleration setting defined on the Troubleshooting tab of the 
Display control panel in Windows. Often, slight reductions of the hardware 
acceleration will solve the problem; however, you might need to reduce the 
acceleration significantly or turn it off completely.

Problem When I try to run a model, AutoMod displays a dialog box asking for 
authorization codes. I’ve already authorized the software.

Solution The edit environment and simulation environment each have 
separate authorization codes. To authorize the simulation environment, type 
the codes labeled Runtime.
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Problem When I run a model, the model graphics don’t appear in the 
Simulation window.

Solution This error could indicate that the software is incompatible with your 
graphics card’s hardware acceleration. To fix the problem, try lowering the 
hardware acceleration setting defined on the Troubleshooting tab of the 
Display control panel in Windows. Often, slight reductions of the hardware 
acceleration will solve the problem; however, you might need to reduce the 
acceleration significantly or turn it off completely.

Problem When I try to run a model in AutoStat, the Select a Model to Run 
dialog box opens before each run.

Solution This error occurs when a model is stored in a location that includes a 
space or special character anywhere in its path. To fix the problem, move the 
model to a directory that does not contain a space or special character in its 
name or in the name of any directory in its path. 

Problem When I close a menu, some remnants of the menu remain visible on 
the screen.

Solution Open the Display Properties dialog box, click the Effects tab, and 
clear Use transition effects for menus and tips. Clearing this option 
prevents menu remnants that occur with some graphics cards.

Problem AutoStat opens but does not execute. An error message is 
displayed. The model does run in AutoMod.

Solution Shorten the model name or place the model higher in your directory 
structure; the entire pathname, including the file name, must contain fewer 
than 72 characters.
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Installing the Network License Server

Overview
The Network License Server (NLS) allows you to run Applied simulation 
products on any machine on a local area network. Users can share licenses of 
AutoMod, AutoSched AP, and all AutoMod modules, such as AutoView, AutoStat, 
and Kinematics. 

The NLS controls how many copies of each product users can run 
simultaneously. Only the NLS machine needs a Sentinel hardware or software 
key installed.

For example, if four users at your company do not all use the Applied software 
at the same time, you might choose to purchase three AutoMod licenses, one 
AutoStat license, and one AutoView license. The NLS allows all of the users 
access to the products but ensures that only the authorized number of licenses 
are in use at one time. In the example below, the products are installed on each 
user’s machine and the NLS is on different machine.

It is also possible to use one of the user’s machines as the NLS machine, as 
shown below.

You can configure multiple license servers using the Simulation License 
Manager; see the AutoMod Help file for more information. 

You can also install the products on a server. See “Installing Applied products 
on a remote server” on page 33 for more information.

Controls the number of 
licenses running on the 
network

Products installed on 
each machineUser User User User

Sentinel 
key

Network License 
Server

NLS and products 
installed on this machine

Products installed on 
each machineUser

Sentinel 
key

Network License 
Server and User

User User User
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Running on a laptop
If you are using a laptop computer, you can authorize Applied software as long 
as the laptop is connected to the network. If you want to use the software 
without a network connection, you need to install a Sentinel key on the laptop 
and authorize the software with local authorization codes.

Installing the Sentinel key
You must first install either the Sentinel software key or the Sentinel hardware 
key as described in the following procedures.

Installing the Sentinel software key
The Sentinel software key is installed using the Sentinel Remote Update System 
(RUS) utility and is locked to the host machine used to run the NLS software.

 To authorize the software using a local software key, you must 
install the key as follows

1. On the computer where you want to install the software key, open the 
SimController. 

2. In the SimController, click File > Software Key Setup. The RUS window 
opens with the first tab Collect Status Information active. 

3. Verify that the Installation of a new protection key option is selected, then 
click Collect Information.

The collected information is used to create a .c2v file, which is a 
“fingerprint” of the computer where the software key will be installed.

4. Navigate to the location where you want to save the .c2v file, enter a file 
name, then click Save.

5. Email the created .c2v file to AutoMod support (see “Software support” on 
page 3). 

6. After AutoMod support receives your .c2v file, they generate your software 
key and then email you a .v2c file. This step requires some time for 
AutoMod support to complete.

7. After you receive the .v2c file from AutoMod support, open the RUS utility 
(see step 2).

8. Click the Apply License File tab of the RUS utility.

9. Click the ... button and navigate to the location of the .v2c file, select the 
file name, and then click Open.

10. Click the Apply Update button to complete the installation of the software 
key.

The software key is now installed.

After installing the software key, you are now ready to install the NLS software; 
see “Installing the NLS software” on page 28 for more information.

Installing the Sentinel hardware key
The Sentinel hardware key is a physical security key that is installed in a 
parallel or USB port on the host machine used to run the AutoMod software.

 Note The installed software key is locked to this computer. If you want 
to move the software key to another computer, see “Transferring a 
Sentinel software key” on page 14
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 To install the Sentinel hardware key

1. Turn off the machine before installing the Sentinel key.

2. Install the key into a parallel or USB port (depending on the key type).

3. Turn on the machine and log in as a user with read/write privileges. 

The Sentinel key is now installed.

Installing the NLS software
Install NLS first and then install other Applied products in the same directory as 
the NLS software. Installing to one directory prevents problems associated with 
having paths to multiple installation directories.

When selecting an installation directory, keep the following in mind:

• NLS cannot be installed in a directory with a space in its name.

• The name of the installation directory cannot contain characters with 
diacritical marks like the umlaut, grave, acute or circumflex accent marks, 
tilde, cedilla, and so on. The directory names (and the names of your 
AutoMod models) should include only standard English letters and 
numbers.

 To install NLS

1. Log in as administrator on the server machine.

Note If the machine is running Windows XP, and you are installing NLS for the 
first time, do the following:

a. Using a text editor, edit the following file:
%SystemRoot%\System32\drivers\etc\services

b. Add the following line to the bottom of the file:
asiserv 5501/tcp # AutoMod License Server

c. Quit the editor.

2. Right-click AutoMod_NLS_version#.exe and select Run as 
administrator to install the Network License Server. Follow the prompts on 
the screen.

3. If you installed the Sentinel drivers, you must restart your computer when 
the installation is complete (click No to restart during installation; wait until 
it is finished to restart your machine).

 Note You can install the USB key into a USB hub; however, the key must 
be installed into one of the hub’s first 10 USB ports. If your hub has more 
than 10 ports, the additional ports are not recognized by the software.

! Important If you are updating an older version of NLS, you must stop the 
Network License Server before installing the new version. For more 
information, see “Stopping the License Server” on page 30.

» Tip You must install the Sentinel drivers if this is the first time you have 
installed the Network License Server; if you are upgrading an existing 
installation, you do not need to install the drivers.



Applied Materials Confidential | 29

Applied AutoMod 12.6.1
Installation Guide

Authorizing the software

 To obtain and enter authorization

1. In the Start menu, click Network License Server > Server Install. An 
authorization dialog box opens, displaying the host name and machine ID.

The License Server Installation dialog box appears.

2. Write down the host name, because you will need it again when running 
software on a client machine (see “Running software on clients” on page 31 
for more information).

3. Click Quit.

4. Give customer support the machine ID and name, and request 
authorization codes in an e-mail file.

5. Place the text file in the \bin directory in the installation directory.

6. Using a DOS prompt, change directories to the \bin directory in the 
installation directory.

7. Type servfax <e-mail> <tmpfile> where <e-mail> is the name of the 
text file customer support sent you and <tmpfile> is a temporary file name 
(do not include the brackets).

8. Type servinst -f <tmpfile> where <tmpfile> is the name of the 
temporary file (do not include the brackets). Your codes are typed for you.

The authorization process creates a file called asiservfile in the \lib directory. 
Do not edit or delete this file, or you will need to reinstall the License Server.

You are now ready to start the license server.

Starting the License Server

 To start the License Server on Windows Vista or Windows 7 & 8

1. From the Windows Start menu, locate the Network License Server 
program group.

2. Right-click Command Prompt Setup.

3. Click Run as administrator.

4. From the command prompt, type asiserv -start to start the License 
Server.

 To start the License Server on Windows Server 2003 or 2008

From a command prompt, type asiserv -start to start the License Server.

The command line option -start runs the license server as a service that 
restarts automatically whenever you reboot the machine. 

The License Server is ready for use. You are now ready to set up the software 
on the client machines (see “Installing software on clients” on page 31 for more 
information). 

 Note If you do not have e-mail, you can obtain authorization codes by 
providing the host name and machine name to customer support. After you 
obtain the codes, start the license server and type each of the codes in the 
authorization dialog box when prompted. When you have typed all the 
codes, click End to close the authorization dialog box.
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Stopping the License Server

 To stop the License Server service

1. Right-click Computer or My Computer.

2. In the shortcut menu, click Manage.

The Computer Management dialog box opens.

3. Expand the Services and Applications entry in the Tree list, then click 
Services.

4. In the list of services, right-click AutoMod License Server.

5. Click Stop.

Restarting the License Server

If you have stopped the License Server, you can restart it using this procedure:

 To restart the License Server

1. Right-click Computer or My Computer.

2. In the shortcut menu, click Manage.

The Computer Management dialog box opens.

3. Expand the Services and Applications entry in the Tree list, then click 
Services.

4. In the list of services, right-click AutoMod License Server.

5. Click Start.

Changing the Sentinel key
You can move the transfer the Sentinel hardware or software key to a different 
machine (for example, when moving the Network License Server from one 
machine to another).

For information about how to transfer the Sentinel software key, see 
“Transferring a Sentinel software key” on page 14.

 To transfer the Sentinel hardware key to a different machine

1. Stop the License Server (see “Stopping the License Server” on page 30).

2. Turn off the machine.

3. Remove the old Sentinel key.

4. Insert the new Sentinel key.

5. Turn on your machine.

6. If necessary, restart the License Server (see “Restarting the License 
Server” on page 30).

 Note You can use the -start command line option to set up the License 
Server as a service, so it restarts automatically whenever you reboot the 
machine. For more information, see “Starting the License Server” on 
page 29. If you do not use this option, you will need to restart the license 
server every time you reboot the machine.
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Installing software on clients

 To install Applied software (for example, AutoMod and AutoStat) on 
client machines

1. Log in as a user with read/write privileges on the machine on which you are 
installing the software.

2. Install the products (using the appropriate instructions for that software), 
but do not authorize them (see “Running software on clients” on page 31). 

3. Repeat steps 1 and 2 for all client machines.

Running software on clients

Running AutoMod

 To run AutoMod on a client

1. Open AutoMod (you can open the software from a command prompt or 
from the Start menu). The Authorization window opens. 

2. Click License Server. The Simulation License Manager opens. 

3. In the Simulation License Manager, Select Server from the Type drop-down 
list and type the name of the machine on which the License Server is 
installed. Type the machine name exactly as it was displayed when you 
used the servinst program to give information to customer support. See 
“Simulation License Manager” in the AutoMod Help File for instructions on 
authorizing your software and managing one or more license servers. 

The software queries the License Server to determine whether a license is 
available. If a license is available, the software runs; otherwise, the software 
waits for a license to become available.

Running AutoMod with AutoView animation
The AutoView software is authorized when you run a simulation that is defined 
to generate AutoView description files.

 To run a simulation on a client while generating AutoView 
description files

1. Open a model in the AutoMod software and edit the run control.

2. Select the AutoView check box to generate animation description files 
during a snap (see the AutoView online help for more information).

3. Run the model. The Authorization window appears.

4. Click License Server. The Simulation License Manager opens. 

5. In the Simulation License Manager, Select Server from the Type drop-down 
list and type the name of the machine on which the License Server is 
installed. Type the machine name exactly as it was displayed when you 
used the servinst program to give information to customer support. See 
“Simulation License Manager” in the AutoMod Help File for instructions on 
authorizing your software. 

The software queries the License Server to determine whether a license is 
available. If a license is available, the software runs; otherwise, the software 
waits for a license to become available.
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Running AutoStat

 To run AutoStat on a client

1. In the Start menu, click AutoStat.

The AutoStat window opens.

2. Click File > Open and navigate to a model that you want to open (the 
model must have been built in AutoMod before it can be opened in 
AutoStat).

3. Click Open to open the model. The Authorization window opens. 

4. Click License Server. The Simulation License Manager opens. 

5. In the Simulation License Manager, Select Server from the Type drop-down 
list and type the name of the machine on which the License Server is 
installed. Type the machine name exactly as it was displayed when you 
used the servinst program to give information to customer support. See 
“Simulation License Manager” in the AutoMod Help File for instructions on 
authorizing your software. 

The software queries the License Server to determine whether a license is 
available. If a license is available, the software runs; otherwise, the software 
waits for a license to become available.

Running the MMS Server

 To run the MMS Server on a client

1. Open a command prompt and type the commands to start the MMS Server 
(see the Model Communications User’s Guide for more information).

A text menu appears.

2. Type 2 to authorize the software using the License Server.

3. At the Name: prompt, type the name of the machine on which the License 
Server is installed. Type the machine name exactly as it was displayed 
when you used the servinst program to give information to customer 
support.

The License Server is queried to determine whether a license is available. If a 
license is free, the software runs. If no licenses are available, it quits.

Running AutoSched AP

 To run AutoSched AP on a client

1. Open the Simulation Controller and click File > Authorize>Authorize 
AutoShed AP. The Simulation License Manager opens. 

2. In the Simulation License Manager, Select Server from the Type drop-down 
list and type the name of the machine on which the License Server is 
installed. Type the machine name exactly as it was displayed when you 
used the servinst program to give information to customer support. See 
“Simulation License Manager” in the AutoMod Help File for instructions on 
authorizing your software.

The software queries the License Server to determine whether a license is 
available. If a license is available, the software runs; otherwise, the software 
waits for a license to become available.
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Installing Applied products on a remote server
It is possible to install Applied software products on a server and run them from 
a client. The products are run on each client, not on the server. This saves disk 
space on users’ machines, but is much slower than having the software 
installed locally. 

The clients share the area on the server containing the software and launch it. 

Satisfying system requirements
To configure a network in this manner, each client machine requires: 

• A network adapter and a network connection that supports the Internet 
Protocol (TCP/IP)

• Windows 7 Ultimate, Windows 7 Professional, Windows Vista Business, or 
Windows 8

• 5 MB of available disk space

Installing the software on the server
Applied recommends using the Network License Server machine for the server.

 To install the software on the server

1. On the server, make a directory for the software.

2. Share the drive that contains the directory.

3. Install the products onto the server from a client. Specify the server’s 
shared drive and directory as the installation path.

4. On the client, set the client’s environment variables to the shared directory 
on the server (see the previous sections).

5. Authorize the client with the Network License Server.

! Important Although running products from a server is technically 
possible, the demands of 3-D rendering make the performance of Applied 
products very slow when run across a network. Therefore, Applied does not 
recommend configuring your network in this manner.

 Note You must set the environment variables for each user on each client.

Network license server and 
software for all platforms installed 
on the server

All software run from 
each machine

Sentinel 
key

Server

User User User User
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Running the software on the clients

 To run the software on the clients

1. Share the server drive that contains the software you want to run.

2. Run the applications.

The NLS checks for license availability.

Checking license availability
You can use the Server Query utility on a PC to determine how many licensed 
copies of Applied software are available for use and how many copies are 
currently in use.

 To run the server query utility

1. In the Start menu, click Network License Server > Server Query. 

2. Type the host name of the server running the NLS software and click OK.

The AutoMod License Server Query dialog box displays with the following 
options:

Troubleshooting
This section contains information about how to solve problems that you might 
experience during and after software installation. If the problem you are 
experiencing is not listed in this section, contact customer support for further 
assistance.

Solving problems during NLS installation

Problem While typing the server’s authorization codes, the following error 
appears: Passwords don’t match. Try again.

Solution This error indicates that the password you typed does not match the 
Sentinel key installed in the machine. Re-type the password and verify that the 
checksum displayed in the dialog box matches the checksum provided with 
your authorization codes. If the checksum matches, but you are still getting the 
error, verify that the machine ID number provided with the authorization codes 
matches the machine ID on the Sentinel key installed in your machine. If they 
do not match, install the correct key or contact customer support for the correct 
codes for the key you are using.

 Note If the applications do not run properly, check the value of the client’s 
ASI and HOME environment variables and ensure that they are pointing to 
the appropriate directories.

Option Function

Update Now Refreshes the list of total and used licenses.

Show Used Shows who is using the selected licenses. (You must select a 
license in the list to display this information.)

Open Host Enables you to specify a new server host name.

Quit Closes the Server Query utility.
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Solving problems opening software on a client machine

Problem When I open the software, the following message appears: Waiting 
for AutoMod license.

Solution This message indicates that all available licenses of the software are 
currently in use. To solve the problem, you need to wait until a license becomes 
available (that is, until someone closes an open instance of the software 
running on your local network).

Problem When I open the software, the following message appears: The 
program tried to start the license server asiserv, but the server 
quit immediately...

Solution This error can occur when you have installed a new version of the 
NLS over an existing version. To solve the problem, reauthorize the software by 
retyping your authorization codes and then start the license server (see 
“Installing the NLS software” on page 28).

Problem When I open the software, a message indicates that the software 
can’t connect to the server machine; a waiting message then appears.

Solution This error might indicate that the License Server is not running. To 
determine whether the License Server is running, perform the following steps 
on the server machine. The steps vary depending on the server’s operating 
system.

 To determine whether the License Server is running

1. Right-click Computer or My Computer.

2. In the shortcut menu, click Manage.

The Computer Management dialog box opens.

3. Expand the Services and Applications entry in the Tree list, then click 
Services.

4. In the list of services, verify that the AutoMod License Server service has 
been started. If it is stopped, restart the license server (see “Restarting the 
License Server” on page 30).

 Note If you are experiencing a software problem not listed in this section, 
it might indicate a problem occurred during installation of the software on 
the client machine. For more information, see the troubleshooting section of 
the installation instructions for the software you are trying to open.

» Tip You can verify which machines on your network are currently using 
software licenses by running the program ServerQuery. For more 
information, see “Checking license availability” on page 34.

 Note If the server is running, the error might indicate that the client 
machine is unable to connect to the server over your local network (in this 
case, contact your network administrator for further assistance).
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